Intrum VideoIdent Call Center longer waiting times expected for today

Incident Report for Intrum

Resolved

We are expecting longer waiting times than usual for today 12.12.2025 from 17:00 to 22:00.
We apologize for the inconvenience.
Posted Dec 12, 2025 - 15:34 CET

Monitoring

We are expecting longer waiting times than usual for today 12.12.2025 from 17:00 to 22:00.
We apologize for the inconvenience.
Posted Dec 12, 2025 - 15:34 CET
This incident affected: Video-Ident and eSigning QES.