HTTPS Certificate replacement for Intrum PROD System

Scheduled for Feb 23, 12:00 - 13:00 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 10, 2026 - 12:19 CET

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 10, 2026 - 12:18 CET

Update

SHA Keys are now available:

SHA1 Fingerprint
50:78:C3:10:61:AC:92:83:B6:CE:37:B0:B5:13:FB:25:27:A1:FE:11

SHA256Fingerprint
9D:1F:8E:38:D4:08:62:E5:D7:0D:05:EC:20:5B:DC:2E:DA:33:B8:9C:4E:E0:9C:7B:6C:DE:D2:2A:A1:6A:54:B2

MD5 Fingerprint
55:04:90:79:85:CB:3B:71:FC:91:71:78:96:21:3C:9B
Posted Feb 10, 2026 - 11:56 CET

Scheduled

Dear customers,

We will rollout our new HTTPS certificates for below domains in February 2026.

Expire Date Prod: 24.02.2026
Rollout Prod: 23.02.2026
Communication of new SHA Keys PROD: 10.02.2026

PROD
- online-ident.ch
- *.online-ident.ch
- *.internal.online-ident.ch

This change will not require downtime and service levels will not be affected.

If you are pinning the SHA Keys on the above domains, then you will need to exchange to the new values.
We will communicate the new SHA Keys via this channel as written above.

Kind Regards,
Intrum Team
Posted Jan 22, 2026 - 15:42 CET
This scheduled maintenance affects: Video-Ident, AutoIdent, and API.