VideoIdent SDK - Android Upgrade Required

Incident Report for Intrum

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 09:17 CET

Monitoring

Dear Customers,

We observed a number of video calls with reduced image quality (green tinge) on Android versions and devices.

We delivered a fixed version of the IDnow SDK and updated the IDnow VideoIdent app in Google’s Play Store to fix the video quality issues.

We request all our customers using the SDK to update to the latest version, found here:
https://github.com/idnow/de.idnow.android/releases
Version 9.7.4.

End users connecting to our Video and eSign services must use the latest IDnow app version, which is typically downloaded before starting the ident.

iOS is not affected.
VideoIdent and eSign Web are not affected.
AutoIdent and other products are not affected.

If you have any questions, please reach out to our support team.
https://intrum.freshdesk.com/support/home
Posted Dec 03, 2025 - 14:49 CET
This incident affected: Video-Ident.