VideoIdent Center Connection Degraded Performance

Incident Report for Intrum

Resolved

Process is back to normal and all calls going smoothly.
Posted Dec 10, 2025 - 10:29 CET

Identified

We are currently experiencing degraded performance for our VideoIdent and eSign Calls, resulting in longer waiting times.
We are working with high priority to improve the situation .
Posted Dec 10, 2025 - 09:19 CET
This incident affected: Video-Ident and eSigning QES.