Intrum Test Robot degraded performance

Incident Report for Intrum

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 10:08 CEST

Monitoring

A fix for the test robot has been implemented and we are seeing successful cases.
Posted Jul 30, 2026 - 11:26 CEST

Investigating

Dear Customers

We are currently experiencing degraded performance with our test robot service.
VideoIdent: Test Robot not triggering
Autoident: 20 Second Delay

Our team is working on fixing this as soon as possible.

Thank you for your understanding.

Intrum Support Team
Posted Jul 16, 2026 - 11:16 CEST
This incident affected: Testsystem.